Netgear FVS318 einrichten & Geschwindigkeitstest

Los geht’s

Von der Arbeit habe ich mir einen älteren Netgear ProSafe VPN Firewall FVS318 geliehen, um das gute Stück mal genauer anzusehen. Schließlich bietet das Teil IPsec, eine Firewall und vieles mehr.
Erstmal interessiert mich aber vor allem die Geschwindigkeit.

Kommt robust daher…

Grundeinstellungen
Also die Einstellungen zurückgesetzt und anschliessen. Erfreulicherweise stehen die wichtigsten Daten (IP, Login Daten) auf dem Gehäuse. Leider wird bei Aufruf der IP 192.168.0.1 zur Konfiguration die Seite im Browser auf routerlogin.net umgeleitet. Somit landet man bei einer Seite von Netgear und es geht erstmal nicht weiter, da die entsprechende Funktion inzwischen nicht mehr vorhanden ist.


… und gleich ein Fehler.

Ist natürlich sinnlos, auf eine Seite weiterzuleiten, die es gar nicht gibt. Und was, wenn man kein Internet hat? Schließlich richtet man sich gerade einen Router ein… leider gibt es diesen sinnlosen Mist bei einigen Hersteller (homelacie.com fällt mir gerade noch ein).

Nach kurzer Suche aber eine Lösung gefunden [1]. Das ist eigentlich simpel. In die hosts Datei (unter Win XP unter C:WINDOWSsystem32driversetc) trägt man folgende Zeile ein:
192.168.0.1 http://www.routerlogin.net
Somit werden alle Anfragen direkt auf das Gerät geleitet. Mit der URL http://www.routerlogin.net/setup.cgi?next_file=start.htm bzw. http://www.routerlogin.net/start.htm kann man jetzt das Setup aufrufen.

Zum testen verbinde ich zwei Rechner, die in verschiedenen Subnetzen
liegen.

Wobei 192.168.10.1 die WAN Schnittstelle ist.

Gateway und DNS gibt es nicht, ohne diese Angaben meckert aber das Setup.
Der Verkehr von 192.168.0.0 -> 192.168.10.0 funktioniert wunderbar. Ping, und auch SMB klappt ohne weitere Konfiguration. In die andere Richtung geht nix.
Der Grund dazu ist in der Firewall zu finden.

Eingehender Verkehr wird grundsätzlich blockiert.

Geschwindigkeitstest
Da die Firewall erstmal nicht weiter interessiert (letztlich will ich das Teil ja, wenn überhaupt, klassich via DSL verwenden), geht es mit dem Test der Durchsatzgeschwindigkeit weiter. Dazu benutze ich NetIO [2][3].
Der Server läuft auf 192.168.10.2 und wird mit win32-i386 -s gestartet. Hier die Ausgabe des Clients.

Die Geschwindigkeit sollte demnach so gerade für ein 16 MBit Verbindung ausreichen. Bei Kabelanbindung oder VDSL ist das schon zu lahm.

Als nächstes kommt dann die VPN Funktion dran. Dafür gibt es dann einen neuen Artikel.

[1] http://decoding.wordpress.com/2007/02/21/netgear-router-19216801-redirects-to-wwwrouterlogincom-how-to-fix-it/

[2] http://www.nwlab.net/art/netio/netio.html

[3] http://www.ars.de/ars/ars.nsf/docs/netio

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s